crates.io unavailable
Incident Report for The Rust Programming Language
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 07:56 UTC
Update
Since the last update, crates.io fully recovered and we are serving traffic as usual. We're continuing to monitor the situation and we'll re-enable the read-only replica again soon.
Posted Mar 22, 2024 - 07:48 UTC
Monitoring
We have identified a problem with our read-only database replica and routed traffic away from it. We are monitoring the recovery, and we will continue investigating the cause of the problem.
Posted Mar 22, 2024 - 07:26 UTC
Investigating
We are investigating the crates.io website and API being unavailable. Downloads from recent Cargo versions should be working, but older Cargo releases relying on the crates.io API are affected.
Posted Mar 22, 2024 - 07:11 UTC
This incident affected: crates.io.