crates.io unavailable
Incident Report for The Rust Programming Language
Resolved
The situation has been stable for the past 20 minutes. We reverted the emergency change to the configuration of the registry index, and we're marking this incident as resolved. We're sorry for the disruption.
Posted Feb 24, 2022 - 17:37 UTC
Monitoring
We're seeing traffic coming back to the crates.io application. We're monitoring the recovery, and we'll revert the emergency registry configuration change once we have confirmation the situation is fully resolved.
Posted Feb 24, 2022 - 17:22 UTC
Identified
Due to an issue to our infrastructure provider, fully resolving the crates.io outage will take longer than expected, so we're executing our disaster recovery plan. We apologize for the disruption this is causing.

Ensuring builds with Cargo keep working is our highest priority, so we made some changes to the registry configuration to bypass the piece of infrastructure responsible for the outage. Download counts will be discarded while this configuration is in effect, and action might be needed on your part to manually fetch the latest registry configuration.

Note that downloads could be slower due to this change, but they should eventually complete.

If you're running builds in CI and do not cache the index, there's no action needed from you: new builds will download the latest index and pickup the configuration changes we made.

If you're running builds in CI and also caching the index, you need to purge those caches to be able to start builds again. Use your CI platform's tooling to accomplish that.

If you're developing on your local machine, you need Cargo to fetch the latest copy of the index. The easiest way to do so is to run this command, which will error out: "cargo install empty-library". After the command errors out, new Cargo invocations will work.
Posted Feb 24, 2022 - 17:06 UTC
Investigating
We're investigating crates.io being unreachable.
Posted Feb 24, 2022 - 16:54 UTC
This incident affected: crates.io.