Degraded performance on crates.io

Incident Report for The Rust Programming Language

Resolved

All endpoints are now operational and available again.
Posted May 20, 2026 - 16:57 UTC

Monitoring

Crates.io is currently under a suspected denial of service effecting the web frontend. The reverse dependency endpoint has been disabled. You will not be able to browse reverse dependencies on crates.io for the duration of the incident. All other operations, publishes and the index are operating normally.
Posted May 20, 2026 - 15:52 UTC
This incident affected: crates.io.