Sparse Index CDN Invalidations Slow to Update

Incident Report for The Rust Programming Language

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 23:33 UTC

Update

The backlog has cleared and all queues are nominal.
Posted Sep 02, 2025 - 23:32 UTC

Update

The sparse index has synchronized and is now up-to-date. CDN updates are still processing.
Posted Sep 02, 2025 - 23:08 UTC

Monitoring

A backlog of CDN invalidations is causing a backlog of approximately 350 crate backlog for sparse index updates and CDN updates. We are monitoring as the queue is worked through.
Posted Sep 02, 2025 - 22:48 UTC
This incident affected: crates.io.