Crate publishes delayed
Incident Report for The Rust Programming Language
Resolved
All pending background jobs have been executed, and the queue is back to a normal state. This incident is now resolved.
Posted Dec 05, 2022 - 21:45 UTC
Identified
We have identified the root cause and applied measures to reduce the length of the background job queue.
Posted Dec 05, 2022 - 21:37 UTC
Investigating
We're investigating a high number of jobs in our background worker queue, slowing down crate uploads.
Posted Dec 05, 2022 - 21:06 UTC
This incident affected: crates.io.