Database upgrade
Incident Report for The Rust Programming Language
Resolved
This incident has been resolved.
Posted May 20, 2024 - 12:26 UTC
Update
Database server upgrade is complete and crates.io should be running at full capacity again now. Hopefully even a bit faster than before due to increased memory on the new database servers.
Posted May 20, 2024 - 12:26 UTC
Monitoring
We noticed a small issue with our database indexes after the upgrade, resulting in several crates not being found anymore. We've reindexed the relevant tables which appears to have fixed the problem. The new follower database is catching up an will soon be available to improve the API response times again.
Posted May 20, 2024 - 12:14 UTC
Identified
We are in the process of upgrading our database servers. This will require a short amount of time in read-only mode and a couple of minutes with degraded performance while our follower database is catching up with the new leader.
Posted May 20, 2024 - 11:17 UTC
This incident affected: crates.io.