Degraded performance on crates.io

Incident Report for The Rust Programming Language

Resolved

Everything continues to look stable, so we can consider this resolved.
Posted Nov 11, 2025 - 01:14 UTC

Monitoring

The 2025 version of "it's always DNS" might be "it's always AI scrapers pretending to be other things".

Our database provider pointed out an expensive endpoint that was being hit just enough by a single IP to cause the incident, but not enough for our normal monitoring setup to detect it. We have blocked that IP and response times appear to be returning to normal.

Continuing to monitor for a few minutes, but this looks good at the moment.
Posted Nov 11, 2025 - 01:04 UTC

Identified

The slowdown is definitely database related, and we are in contact with our upstream provider to see if we can track down what the root cause might be.
Posted Nov 11, 2025 - 00:15 UTC

Investigating

crates.io is currently experiencing degraded performance on any requests that hit the database (which is basically anything in the API except crate downloads). We are investigating.
Posted Nov 10, 2025 - 23:56 UTC
This incident affected: crates.io.