Crate indexes not updating

Incident Report for The Rust Programming Language

Resolved

Crates published since the background workers were restarted are now appearing in the index, and the backlog of background jobs has been processed successfully.
Posted 1 month ago. May 13, 2025 - 07:44 UTC

Monitoring

Indexes are up to date, and we are monitoring the background workers to ensure they continue to pick up new jobs.
Posted 1 month ago. May 13, 2025 - 07:41 UTC

Identified

Background workers have been restarted.
Posted 1 month ago. May 13, 2025 - 07:39 UTC

Investigating

Since approximately 05:20 UTC, index entries in the Git and sparse crate indexes have not been published. We are investigating.
Posted 1 month ago. May 13, 2025 - 07:37 UTC
This incident affected: crates.io.