crates.io database maintenance
Incident Report for The Rust Programming Language
Resolved
Scheduled maintenance finished successfully.
Posted Dec 21, 2023 - 11:13 UTC
Update
Scheduled maintenance on our database is starting.

We expect this to take less than 15 minutes to complete. During maintenance crates.io will only be available in read-only mode: downloading crates and visiting the website will still work, but logging in, publishing crates, yanking crates or changing owners will not work.
Posted Dec 21, 2023 - 10:59 UTC
Investigating
The crates.io team will perform a database maintenance on 2023-12-21 from 11:00 to 11:15 UTC.

We expect this to take less than 15 minutes to complete. During maintenance, crates.io will only be available in read-only mode: downloading crates and visiting the website will still work, but logging in, publishing crates, yanking crates, or changing owners will not work.
Posted Dec 20, 2023 - 14:31 UTC
This incident affected: crates.io.