DoS Attack

Incident Report for The Rust Programming Language

Monitoring

We have deployed countermeasures and our servers are largely back to normal again. We keep monitoring the situation. If you encounter any issues please let us know!
Posted Jul 11, 2026 - 15:06 UTC

Update

We are continuing to investigate this issue.
Posted Jul 11, 2026 - 14:22 UTC

Investigating

We are experiencing what looks like a coordinated DoS attack against our API servers. We are monitoring the situation and are assessing our reaction. Crate downloads and dependency resolution through the sparse/git index should not be affected.
Posted Jul 11, 2026 - 14:22 UTC
This incident affects: crates.io.