Git index slow to update

Incident Report for The Rust Programming Language

Resolved

The background worker has caught up, and crate publishes are now updating normally in both indexes.
Posted Feb 12, 2026 - 19:46 UTC

Identified

The crates.io background worker is having a bad morning, and a backlog of Git index updates has accumulated. We have given the worker some coffee and it's catching up, but index updates for newly-published crates are running about an hour behind right now.

The sparse index (used by default by all modern Rust versions) is unaffected.
Posted Feb 12, 2026 - 19:36 UTC
This incident affected: crates.io.