Broken download links
Incident Report for The Rust Programming Language
Resolved
The bugfix has been merged and deployed to production. We have adjusted our test suite to reduce the chances of this issue appearing again in the future.
Posted Jul 20, 2023 - 14:15 UTC
Monitoring
After a deployment we noticed an elevated number of download requests, that were caused by crates.io generating broken download URLs and cargo retrying those downloads again and again. We have rolled back the deployment to fix the issue in production. The bug is already identified and we are working on a long-term fix.
Posted Jul 20, 2023 - 12:17 UTC
This incident affected: crates.io.