Request timeouts/Slow responses
Incident Report for The Rust Programming Language
Resolved
All of our affected infrastructure has recovered and full functionality has been restored. Some caches may require a bit of warming up, so some slow responses should still be expected.
Posted Dec 22, 2021 - 15:07 UTC
Update
Our service provider is still working to restore full functionality, but unfortunately there is no ETA for full recovery at this time. We continue to monitor the situation.
Posted Dec 22, 2021 - 14:39 UTC
Monitoring
An outage of one of our service providers impacts our primary database and one of our application dynos. Currently, write operations will fail (uploading new crates, ...) and downloads will not be counted. About 25% of all download requests hit the affected dyno and will fail with a timeout. Cargo itself should be mostly unaffected due to retries.
Posted Dec 22, 2021 - 13:02 UTC
Update
We are continuing to investigate this issue.
Posted Dec 22, 2021 - 12:37 UTC
Investigating
We are currently investigating an incident that causes slow responses and request timeouts on crates.io.
Posted Dec 22, 2021 - 12:27 UTC
This incident affected: crates.io.