Intermittent timeouts on API endpoints
Incident Report for The Rust Programming Language
Resolved
crates.io continues to operate normally, and no further performance degradation or timeouts have been observed.
Posted Feb 14, 2024 - 19:25 UTC
Monitoring
Restarting the dynos has restored service, but we are still investigating the root cause of the issue, and continue to monitor crates.io performance.
Posted Feb 14, 2024 - 18:50 UTC
Investigating
Some crates.io endpoints are timing out at present, including the summary route that drives the crates.io home page. We are investigating. Crate downloads are unaffected.
Posted Feb 14, 2024 - 18:45 UTC
This incident affected: crates.io.