Failing requests to crates.io
Incident Report for The Rust Programming Language
Resolved
The incident has been resolved. Traffic and error rates are back to normal levels.

The root cause has been identified and we are assessing solutions to avoid it from happening again in the future.
Posted Dec 27, 2023 - 17:11 UTC
Update
Download traffic is being treated and counted regularly again. We are continuing to monitor for any further issues.
Posted Dec 27, 2023 - 15:45 UTC
Monitoring
Download traffic has been temporarily redirected and the system is recovering. We are monitoring the situation.
Posted Dec 27, 2023 - 14:37 UTC
Investigating
We are currently investigating this issue.
Posted Dec 27, 2023 - 14:24 UTC
This incident affected: crates.io.